AMD Catalyst 12.9 released - Install Guide (updated)

The latest AMD Catalyst 12.9 was released yesterday (13/9/12) . The most significant change here is that Catalyst 9 improves your embedded Radeon graphics. For example if you're using a netbook with an AMD CPU, then you have better support for its embedded IGPU, like E6760, E6460 etc.

Last but not least, the AMD hasn't updated their website, thus this link is located under embedded graphics, not PC Desktop. Hopefully they will update their website during the next 24 hours.

[toggle title="Changelog from Phoronix"]

Fix startx failure on PowerXpress A+A platforms
- Fix performance downgrade with 3DMarkVantage
- Fix startx failure on some specific ASICs
- Fix PowerPlay settings not persistent after reboot
- Fix problem that the hardware information is shown twice in AMD CCC:LE for Power Saving mode of PowerXpress A+A
- Fix severe corruption when switch between multiple X servers
- Fix cursor disappear when open AMD CCC:LE with specific steps
- Fix suspend/resume hang on PowerXpress A+A in Power-Saving mode
- Fix system hang after panning
- Fix system font change after enable Xinerama
- Fix X crash when run 32bit AMD CCC:LE on 64bit system
- Fix the issue that monitor goes into sleep for some ASICs after kill X

[/toggle]

Click to download the drivers for 64/32 bit (the package contains both the 32-bit and 64-bit driver.).

[button color="orange" link="http://www2.ati.com/drivers/embedded/9.00-120815a-146426C-EDG_Direct.zip"]Download 32/64bit[/button]

Currently you can't install this driver using Xorg-Edgers PPA because the repository has not been updated yet. You have to built it by you own following the hard(manual) way.


The hard (manual) way


[toggle title="First install of AMD Catalyst"]
#First install of AMD Catalyst
#prerequisite packages#
sudo apt-get install build-essential cdbs dh-make dkms
sudo apt-get install execstack dh-modaliases fakeroot libqtgui4

# If you are 64 bit, install these too
sudo apt-get install ia32-libs ia32-libs-multiarch:i386
sudo apt-get install lib32gcc1 libc6-i386
cd /usr ; sudo ln -svT lib /usr/lib64

# Go into your Downloads folder (I suppose you have already download the driver)
cd Downloads

# Make the package executable
chmod +x amd-driver-installer-9.00-x86.x86_64.run

# Create and install deb packages
sudo sh ./amd-driver-installer-9.00-x86.x86_64.run --buildpkg Ubuntu/precise
sudo dpkg -i fglrx*.deb

# Enable new settings
sudo aticonfig --initial -f

# Reboot you PC

[/toggle]

[toggle title="Upgrade from AMD Catalyst 12.x to 12.9"]
# eg Upgrade from AMD Catalyst 12.8 to 12.9
# Go into your Downloads folder (I suppose you have already download the driver)
cd Downloads

# Make the package executable
chmod +x amd-driver-installer-9.00-x86.x86_64.run

# Create deb packages
sudo sh ./amd-driver-installer-9.00-x86.x86_64.run --buildpkg Ubuntu/precise

# Force overwrite the older packages with the new ones
sudo dpkg --force-overwrite -i *.deb

# Reboot you PC

If want to unistall them
sudo apt-get remove --purge fglrx fglrx_* fglrx-amdcccle* fglrx-dev*

[/toggle]

Thanks to our reader:Yannis Tsismentzoglou

Comments

  1. There is no fglrx-installer in the repository, only fglrx. I going with that one and see what happens...

    ReplyDelete
  2. Nope...don't do it!!! :P

    ReplyDelete
  3. When I purged the repository it said something about accepting a solution. I pressed yes and now I m not able to enable the discrete card to install manually the drivers. Using switcheroo I can use the intel card but when I switch to ati it hangs. I think I lost the open driver and I can't get it back...(shit...that's where the phrase "if it ain't broken don't fix" goes....

    ReplyDelete
  4. I get
    E: Unable to locate package fglrx-installer
    when using Xorg-Edgers ppa...

    ReplyDelete
  5. try sudo apt-get install fglrx fglrx-amdcccle

    ReplyDelete
  6. Tried that but after reboot ubuntu wont get to the login screen...The xorg seems fine.The thing is that I when I tried to run the automated installer it said no supported graphical adapter or something like that. I have hybrid graphics with the 6770m. Maybe it's not supported by this driver? I don't know...

    ReplyDelete
  7. Yannis TsismentzoglouSeptember 16, 2012 at 1:43 AM

    8.980-0ubuntu1~xedgers~precise1 is definitely not 9.00 that catalyst 12.9 is...
    it's not even catalyst 12.8 which was 8.982...

    ReplyDelete
  8. Holy duck you're right! Sorry for that!

    ReplyDelete
  9. For those who wants to try it out with Ubuntu 12.10... It Doesn't Work for most cards (IF NOT ALL)

    ReplyDelete
  10. Instead of building the deb packages use the installer itself and it will hopefully work.

    ReplyDelete
  11. ATI doesn't support yet the X.org and the kernel of 12.10. Hopefully once 12.10 is in RC, it will support it

    ReplyDelete
  12. There is no ATI. Only AMD.
    Anyway, they both sucks. nVIDIA ftw :P

    ReplyDelete
  13. Damn.... years of using the word ATI... I just cant get used to that AMD is also a graphic cards company...

    ReplyDelete
  14. since it has not been released for the desktop as 12.9 what do you expect?

    ReplyDelete
  15. My friend duh, according to the original article this driver was the "new" catalyst and amd just "forgot" to update their links. So it's not entirely our fault (or my fault) that we tried this out.Personally I thought someone tried this already. One advice guys, first check what you write and then publish it (at least the articles that have to do with the system's stability). Just a friendly advice and nothing more! :)

    ReplyDelete
  16. It's nice to have such a valuable feedback from our readers. We promise to be more careful next time Chisao. Thanks for your advices my friend.

    ReplyDelete
  17. Is this version even offiicial?

    ReplyDelete
  18. Yup. Here's the official link: http://support.amd.com/us/gpudownload/embedded/Pages/embedded_linux.aspx

    ReplyDelete
  19. is this beta? curious

    ReplyDelete
  20. Panos, any chance there will be a guide for Ubuntu 12.10? Having a little trouble so far.

    ReplyDelete
  21. @google-73cc18611f4bc0f720d3c487c462ebeb:disqus If you have an AMD 4xxx series as I do, there is no hope. They have stoped supporting it and so far the driver doesn't seem to bee compatible with 12.10. If you have a 4xxxx series graphics card and you are playing games then stay with 12.04, it is supported with updates for 5 years. If not then upgrade to 12.10 but you will stay with open source driver

    ReplyDelete
  22. Check the new article Salih http://utappia.org/howto/how-to-fix-your-amd-graphics-in-ubuntu-12-10/

    ReplyDelete
  23. http://utappia.org/howto/how-to-fix-your-amd-graphics-in-ubuntu-12-10/

    ReplyDelete

Post a Comment

Popular posts from this blog